Ampeg V4.com

forum

You are not logged in.

#1 2013-02-13 09:39:24

almiknob
Member
Registered: 2010-07-26
Posts: 32

GU-12 REVERB ISSUE

Hi, I have a GU-12 found in auction.
The reverb was very weak and then no reverb on guitar sound now.
If I shake the reverb unit, I can hear the crush sound.

I have done and checked the following matter.
1. reverb tank wiring(coil measurement : 156 & 170 ohm)
2. tighten connectors of the tank
2. cleaning tube pins & sockets

Any advice is appreciated! Thanks.

Offline

 

#2 2013-02-13 11:33:27

hangman
Banned
From: Seattle Washington
Registered: 2006-09-04
Posts: 1848

Re: GU-12 REVERB ISSUE

Did you try a new 6cg7?

Offline

 

#3 2013-02-13 14:31:44

almiknob
Member
Registered: 2010-07-26
Posts: 32

Re: GU-12 REVERB ISSUE

Hi,hangman.
6cg7 ?
My GU-12 has 12AX7,6U10,12DW7 and a pair of 7591.
Should I replace with 6cg7 ?

Offline

 

#4 2013-02-13 16:08:51

hangman
Banned
From: Seattle Washington
Registered: 2006-09-04
Posts: 1848

Re: GU-12 REVERB ISSUE

Ah yes...  The gu12 uses the 6U10 for reverb. My mistake.   You could try replacing that.   You could also check the foot switch jack.

Offline

 

#5 2013-02-15 08:08:26

almiknob
Member
Registered: 2010-07-26
Posts: 32

Re: GU-12 REVERB ISSUE

Problem solved!
When I  checked footswitch wiring,found reverb input cable didn't connect to earth. Then I soldered, reverb came again!
I don't know why the cable was shaved off its shield...
Anyway,thank you very much hangman!
You mentioned and jogged my thought process.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson