Ampeg V4.com

forum

You are not logged in.

#1 2013-05-22 21:59:49

kuttlefish
New member
Registered: 2013-05-22
Posts: 1

Any good techs in New Orleans / Baton Rouge area?

I have a VT-22 in need of an overhaul... probably just a cap job, but I've got some extra money and I want to finally give this thing the TLC it deserves.  It's been mostly reliable over the years, but the few techs I've taken to seem to look shocked and confused when I bring it in.

Anyone know of someone in the New Orleans / Baton Rouge / gulf coast area who is "the guy" when it comes to Ampeg v-series amps?  I'm willing to travel if I can find someone who knows these things inside and out.

----------------

FWIW: The amp was working before I moved across country 5 years ago.  It was probably a good 6-8 months after that before I fired it back up.  I initially got all sorts of static and popping sounds due to bad tubes.  Now it's "working", but at minimal volume.  At 12:00 it sounds like a 1 watt amp and very bass heavy.  Tone controls don't seem to do much unless they're maxed or all the way off. No more volume beyond 12:00, just some light overdrive.  Power tubes are groove tubes from 8 years ago.  They've never given me a problem, but haven't been changed since the move.  I also have some old 7027's in various states of use... but swapping those in doesn't change the sound for better or worse.  All the preamp tubes are new, including a 6k11 from tube depot.  All are stock values except for a 12bh7 in place of the 12au7. 

The reverb never worked except for one glorious moment when I was pulling preamp tubes to find which ones were problematic.  Not sure why that happened, don't remember which tube I pulled to make it work, haven't been able to recreate the event.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson